help .net framework

Oct 19, 2009 at 1:23 PM

despite having downloaded everything from .net framework 1.1 to 4 my liveupload to facebook publishing button on Windows Live photo gallery still prompts the error message 'requires .net framework 2.0 or higher? Please help it's very frustrating, have I not installed the framework correctly (I have added service packs and security updates?) or am I missing something important?