Unhandled exception during first authorization, cannot upload

Apr 19, 2009 at 10:06 PM
I am getting the same error message after trying to install the plug in today. I have removed and reninstalled the plug in, rebooted, and made sure IE is default browser all without success.
Coordinator
Apr 19, 2009 at 10:23 PM
What Regional and Language Settings are you guys running in Windows? Have you changed it to something non-US English?

Are you running Facebook with any different language settings besides US English?

Thanks,
Will
Apr 19, 2009 at 10:30 PM

None. US English only here. Never have had it set to anything else. And thanks for the quick reply back

Scott

From: DuFF [mailto:notifications@codeplex.com]
Sent: Sunday, April 19, 2009 3:24 PM
To: scott.adelman@live.com
Subject: Re: Unhandled exception during first authorization, cannot upload [liveuploadfacebook:53773]

From: DuFF

What Regional and Language Settings are you guys running in Windows? Have you changed it to something non-US English?

Are you running Facebook with any different language settings besides US English?

Thanks,
Will

Read the full discussion online.

To add a post to this discussion, reply to this email (liveuploadfacebook@discussions.codeplex.com)

To start a new discussion for this project, email liveuploadfacebook@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe on codePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at codeplex.com

Apr 20, 2009 at 5:46 AM
I also tried it on another computer to see if it was perhaps related to some program or issue on the first computer. Hate to report that it showed up with the same error on the second computer as well. Hope that information helps with the troubleshooting
Apr 22, 2009 at 3:51 AM
Thought I would give some follow up. I think I solved the issue. I removed the check mark where it asked me if I wanted to remain logged in so I would not need to authorize every upload (sorry for the parphrasing). Anyway unchecked that box and then tried. It works great now. Not really sure where the issue is specifically but at least I found the cure. Thanks Scott
Coordinator
Apr 22, 2009 at 4:49 AM
I've found a temporary work around: Use Facebook to add a profile picture. You can use any picture (even a blank one).

@scottadelman, did you happen to add a profile picture?

This bug recently popped up because Facebook made a slight change to their API. Just recently, Facebook started returning a "Profile Pictures" album when my plug-in asks Facebook for a list of your albums. My plug-in expects all albums returned by the Facebook API to contain the the date they were created and the date they were last modified, however an empty "Profile Pictures" album does not contain these attributes. Therefore, when I try to read these attributes from the empty album an exception is thrown.

Thanks everyone for bringing this to my attention, I'll see if I can get a fix out soon.

-Will
Apr 22, 2009 at 4:57 AM
Sounds like you are on to the solution. I indeed added my profile picture by another method and then the plug in started working as you suspected it would. Thanks for all your effort and great work. Regards
Scott




From: [email removed]
To: [email removed]
Date: Tue, 21 Apr 2009 21:49:53 -0700
Subject: Re: Unhandled exception during first authorization, cannot upload [liveuploadfacebook:53773]

From: DuFF
I've found a temporary work around: Use Facebook to add a profile picture. You can use any picture (even a blank one).

@scottadelman, did you happen to add a profile picture?

This bug recently popped up because Facebook made a slight change to their API. Just recently, Facebook started returning a "Profile Pictures" album when my plug-in asks Facebook for a list of your albums. My plug-in expects all albums returned by the Facebook API to contain the the date they were created and the date they were last modified, however an empty "Profile Pictures" album does not contain these attributes. Therefore, when I try to read these attributes from the empty album an exception is thrown.

Thanks everyone for bringing this to my attention, I'll see if I can get a fix out soon.

-Will


Rediscover Hotmail®: Get quick friend updates right in your inbox. Check it out.
Coordinator
Apr 22, 2009 at 2:56 PM
@xWakawaka: Go to your Facebook profile, then click the Photos tab, then scroll down to your albums. Do you have any empty albums ("0 photos")? If so, can you try adding at least one picture to each album and then see if my plug-in works?